Notifications
Clear all

[Resolvido] Índice Corresp com Datas

3 Posts
2 Usuários
1 Reactions
1,834 Visualizações
(@synth)
Posts: 70
Trusted Member
Topic starter
 

Saudações, prezados,

 

Estou tendo dificuldades com 3 fórmulas dentro de uma planilha, onde ela é abastecida com os dados do IPCA. A planilha de referência possui dados com datas apenas em meses e anos, e a tabela que eu quero que puxe os dados é composta por datas onde os dias também variam. Tentei montar 3 fórmulas, mas não consegui e maneira eficiente. Os problemas que encontrei na planilha são: 1. a fórmula do índice/corresp com data não puxa os dados corretamente; 2. utilizei uma fórmula de juros composto pra descobrir o valor acumulado do ano, mas acredito que deva ter alguma fórmula que considere o ano pra fazer esse cálculo; 3. o de acumulado do ano eu não tenho ideia de como fazer.

Os prezados poderiam me ajudar?

 
Postado : 12/07/2022 10:30 am
EdsonBR
(@edsonbr)
Posts: 1057
Noble Member
 

@Synth, boa tarde

Quanto ao seu problema 1), a fórmula do ÍNDICE/CORRESP parece estar incorreta mesmo (as referências estão todas trocadas, pelo que entendi).

Tente usar essa na G3 e arraste:

=ÍNDICE($A$3:$B$512; CORRESP(DATA(ANO(F3); MÊS(F3); 1); $A$3:$A$512; 0); 2)

 

Quanto aos itens 2 e 3 não estou seguro se com essa alteração feita pela nova fórmula ainda ficaria coerente com aquilo que vc informou lá no arquivo que "Resultados da fórmula estão corretos". O que deveria se esperar? Os 12 últimos valores? Os 12 últimos meses, independentemente de que mês se esteja? Não conheço a metodologia do cálculo do IPCA, mas acredito que o nosso colega @JSCOPA10 daqui do fórum também possa contribuir...

 
Postado : 12/07/2022 4:04 pm
Synth reacted
(@synth)
Posts: 70
Trusted Member
Topic starter
 

@EdsonBR, obrigado pela ajuda!

 

A fórmula funcionou. Através dela, consegui bolar um jeito pra realizar os outros itens.

 

Att,

 
Postado : 18/07/2022 9:39 am