Notifications
Clear all

Formula excel

6 Posts
2 Usuários
0 Reactions
794 Visualizações
(@acido)
Posts: 3
New Member
Topic starter
 

Galera por favor alguém me ajuda.....

Na planilha em anexo tenho uma tabela pelo qual preciso procurar valores que são os seguintes :

 

coluna A devera ser igual coluna M

coluna B devera ser menor ou igual aos valores da coluna N

a da coluna D de estar entre as datas da coluna P e Q 

nessas condições na coluna E retornar o valor da coluna O.

 

 

 
Postado : 05/10/2022 3:37 pm
Tags do Tópico
(@osvaldomp)
Posts: 852
Prominent Member
 

Experimente:

=SE(E(A2=M2;B2<=N2;E(D2+0>=P2;D2+0<=Q2));O2;"")

Osvaldo

 
Postado : 05/10/2022 8:37 pm
(@acido)
Posts: 3
New Member
Topic starter
 

@osvaldomp Não deu certo
retornou 0

 
Postado : 05/10/2022 10:23 pm
(@osvaldomp)
Posts: 852
Prominent Member
 

Disponibilize uma nova planilha com alguns dados representativos e coloque os resultados esperados para cada caso com as necessárias explicações na própria planilha.

Osvaldo

 
Postado : 06/10/2022 8:55 am
(@acido)
Posts: 3
New Member
Topic starter
 

@osvaldomp Segue a nova planilha com uma explicação mais clara
agradeço se conseguirem me ajudas

 
Postado : 06/10/2022 9:45 am
(@osvaldomp)
Posts: 852
Prominent Member
 

O seu resultado em E3 eu entendi e a fórmula que passei retorna resultado igual ao seu, ou seja 6,12. No entanto o seu resultado em E4 eu não entendi e você não explicou como chegou a ele.

Analisando os dois resultados que você colocou nas células acima, E3 e E4, com base nos critérios que eu entendi que você quer.

seu resultado em E3:
se A3 = M3 ~~~> OK
se B3 <= N3 ~~~> OK
se D3 estiver no intervalo entre as datas de P3 e Q3 ~~~> OK
o seu resultado e o resultado da fórmula que passei são iguais ~~~> 6,12

seu resultado em E4:
se A4 = M4 ~~~> OK
se B4 <= N4 ~~~> não atende ao critério, pois B4=97,06 e N4=2
nesse caso a fórmula retorna vazio, no entanto você colocou 6,12.

Você precisa explicar esta sua observação "O valor de 6,12 da celula E3 e E4 é o mesmo da O3".
Com base nos seus critérios, eu entendi que a fórmula deveria analisar linha por linha, no entanto você "puxou" em E4 o valor de outra linha, de O3.

Osvaldo

 
Postado : 06/10/2022 11:44 am